Showing posts with label If else Conditionals Basic. Show all posts
Showing posts with label If else Conditionals Basic. Show all posts

Friday, March 19, 2021

If else conditions in C++

 

Q. Write a program that takes a character as input and prints either 1, 0 or -1 according to the following rules.

1, if the character is an uppercase alphabet (A - Z)

0, if the character is a lowercase alphabet (a - z)

-1, if the character is not an alphabet

Input format :
Single Character
Output format :
1 or 0 or -1
Constraints :
Input can be any character
Sample Input 1 :
v
Sample Output 1 :
0
-------------------------------------------------------------------------------------------------------
Code:
#include<iostream>
using namespace std;

int main() 
{
	char ch;
	cin >> ch;
	if(ch >= 65 && ch <= 90)
		cout << "1";
	else if(ch >= 97 && ch <=122)
		cout << "0";
	else
		cout << "-1";
        return 0;
}
-------------------------------------------------------------------------------------------------------
Output:


Download File: ⚓Click here

Description:
In this program we have declared a character variable "ch" and taken input in it. Next thing 
is we are checking the ASCII values of the inputted character belongs to a particular range or
not. If belongs to that range and fulfill the condition then the respective "0" or 1 will be print-
ed  otherwise else statement will be executed.

You may also like:

If else conditions in C++